home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / ieee80211-1.1.13-r1 / ieee80211-1.1.13-r1.ebuild < prev    next >
Text File  |  2006-05-11  |  3KB  |  94 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/ieee80211/ieee80211-1.1.13-r1.ebuild,v 1.2 2006/04/22 14:39:39 brix Exp $
  4.  
  5. inherit eutils linux-mod
  6.  
  7. # The following works with both pre-releases and releases
  8. MY_P=${P/_/-}
  9. S=${WORKDIR}/${MY_P}
  10.  
  11. DESCRIPTION="Generic IEEE 802.11 network subsystem for Linux"
  12. HOMEPAGE="http://ieee80211.sourceforge.net"
  13. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
  14.  
  15. LICENSE="GPL-2"
  16. SLOT="0"
  17. KEYWORDS="~amd64 ~ppc x86"
  18.  
  19. DEPEND=""
  20.  
  21. IUSE="debug"
  22. BUILD_TARGETS="modules"
  23. MODULE_NAMES="ieee80211(net/ieee80211:)
  24.             ieee80211_crypt(net/ieee80211:)
  25.             ieee80211_crypt_wep(net/ieee80211:)
  26.             ieee80211_crypt_ccmp(net/ieee80211:)
  27.             ieee80211_crypt_tkip(net/ieee80211:)"
  28.  
  29. CONFIG_CHECK="NET_RADIO CRYPTO_ARC4 CRYPTO_MICHAEL_MIC CRC32 !IEEE80211"
  30. ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
  31. ERROR_CRYPTO_ARC4="${P} requires support for ARC4 cipher algorithm (CONFIG_CRYPTO_ARC4)."
  32. ERROR_CRYPTO_MICHAEL_MIC="${P} requires support for Michael MIC keyed digest algorithm (CONFIG_CRYPTO_MICHAEL_MIC)."
  33. ERROR_CRC32="${P} requires support for CRC32 functions (CONFIG_CRC32)."
  34. ERROR_IEEE80211="${P} requires the in-kernel version of the IEEE802.11 subsystem to be disabled (CONFIG_IEEE80211)"
  35.  
  36. pkg_setup() {
  37.     linux-mod_pkg_setup
  38.  
  39.     if kernel_is 2 4; then
  40.         die "${P} does not support building against kernel 2.4.x"
  41.     fi
  42.  
  43.     if [[ -f ${KV_DIR}/include/net/ieee80211.h ]] || \
  44.         [[ -f ${KV_OUT_DIR}/include/config/ieee80211.h ]] || \
  45.         egrep -q "^#(un)?def.*(CONFIG_IEEE80211.*)" ${KV_OUT_DIR}/include/linux/autoconf.h; then
  46.         eerror
  47.         eerror "Your kernel source contains an incompatible version of the"
  48.         eerror "ieee80211 subsystem, which needs to be removed before"
  49.         eerror "${P} can be installed. This can be accomplished by running:"
  50.         eerror
  51.         eerror "  # /bin/sh ${FILESDIR}/remove-old ${KV_DIR}"
  52.         if [ "${KV_DIR}" != "${KV_OUT_DIR}" ]; then
  53.             eerror "  # /bin/sh ${FILESDIR}/remove-old ${KV_OUT_DIR}"
  54.         fi
  55.         eerror
  56.         eerror "Please note that this will make it impossible to use some of the"
  57.         eerror "in-kernel IEEE 802.11 wireless LAN drivers (eg. orinoco)."
  58.         eerror
  59.         die "Incompatible in-kernel ieee80211 subsystem detected"
  60.     fi
  61.  
  62.     if ! (linux_chkconfig_present CRYPTO_AES_586 || \
  63.           linux_chkconfig_present CRYPTO_AES_X86_64 || \
  64.           linux_chkconfig_present CRYPTO_AES); then
  65.         eerror "${P} requires support for AES cipher algorithms."
  66.         die "CONFIG_CRYPTO_AES{_586,_X86_64} support not detected"
  67.     fi
  68.  
  69.     BUILD_PARAMS="KSRC=${KV_DIR} KSRC_OUTPUT=${KV_OUT_DIR}"
  70. }
  71.  
  72. src_unpack() {
  73.     local debug="n"
  74.  
  75.     unpack ${A}
  76.  
  77.     cd ${S}
  78.     epatch ${FILESDIR}/${P}-cflags.patch
  79.  
  80.     use debug && debug="y"
  81.     sed -i \
  82.         -e "s:^\(CONFIG_IEEE80211_DEBUG\)=.*:\1=${debug}:" \
  83.         ${S}/Makefile || die
  84. }
  85.  
  86. src_install() {
  87.     linux-mod_src_install
  88.  
  89.     insinto /usr/include/net
  90.     doins net/*.h
  91.  
  92.     dodoc CHANGES
  93. }
  94.